Logiss.ru

Ваша компьютерная помощь
3 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Настройка маршрутизатора Cisco

Как настроить роутер Cisco: пример и реализация от WiFiGid

Всем привет! Сегодня я на простом примере расскажу вам про настройку роутера Cisco (2911, 1841, 881 и другие модели). Я выдумал некую простую схему с примером, которая позволит вам понять, как подключить локальную сеть к интернету через наш маршрутизатор. Я покажу пример настройки через консоль. Но вы можете делать конфигурирование через программу «Cisco Packet Tracer» – видеоинструкцию смотрим в конце статьи.

Пример подключения

Представим себе, что у нас есть один роутер Cisco. С помощью маршрутизатора мы должны подключить офис с несколькими компьютерами. Для коннекта всех локальных машин будем использовать коммутатор. Fa 4 и Fa 0 – это внешний и внутренний физический интерфейс. Также у нас есть:

  • 277.146.101.1 – это шлюз провайдера.
  • 277.146.101.2 – это внешний IP адрес роутера, его выдает провайдер.
  • 192.168.1.1 – это локальный IP адрес.

Как настроить роутер Cisco: пример и реализация от WiFiGid

Я думаю, схема достаточно понятная и простая.

ШАГ 1: Подключение к маршрутизатору

Для подключения мы будем использовать вот такой вот кабель, который обычно идет в комплекте со всем подобным оборудованием.

Как настроить роутер Cisco: пример и реализация от WiFiGid

С одной стороны консольного кабеля должен быть COM-порт (RS 232). Подключаем один конец в CONSOLE (может иметь надпись CON) порты.

Как настроить роутер Cisco: пример и реализация от WiFiGid

Вы можете столкнуться с проблемой, что у современных компов и ноутов нет подобного входа. Поэтому можно использовать USB переходник.

Как настроить роутер Cisco: пример и реализация от WiFiGid

После подключения скачиваем программку PuTTY – она бесплатная и достаточно удобная. Очень важный момент – в разделе «Connection type» после запуска установите значение «Serial».

И далее нажимаем по кнопке «Open». Если у вас возникли трудности и подключение не происходит, то проверьте в «Диспетчере устройств», какой COM порт используется. Может быть баг, что порт указан не тот. Особенно этот баг проявляется при использовании переходника USB-COM.

Как настроить роутер Cisco: пример и реализация от WiFiGid

Далее вы должны увидеть приветственную надпись в запрос ввода логина и пароля.

ШАГ 2: Reset настроек

Итак, в первую очередь нам нужно полностью очистить старые настройки – они нам ни к чему, все будем делать с нуля (так сказать). Изначально вы увидите вот такую надпись:

Но нам нужно запустить роутер с правами администратора, чтобы вместо стрелочки стояла решетка (#). Для этого вводим команду:

Теперь сначала удаляем старый конфиг, а потом ребутаем аппарат:

router# write erase
router# reload

Нужно будет немного подождать. После этого роутер загрузится и выведет сообщение – использовать стандартную конфигурацию? – отвечаем:

Как настроить роутер Cisco: пример и реализация от WiFiGid

ШАГ 3: Конфигурация интерфейсов

В первую очередь давайте назовем наше устройство для удобства обращения через команду. Я назвал его: «WIFIGID-ROUTER» – смотрим на картинку. Вообще, если у вас будут возникать какие-то вопросы по командам, то смотрите на схему в начале статьи. Итак, обзываем наш роутер:

router#conf t
router (config)#hostname WIFIGID-ROUTER

После этого вместо «router» вы должны увидеть свое название. Вспомним, что у роутера есть два интерфейса,

Внутренний (связь с локальной сетью) – с адресацией:

Внешний (связь с глобальным интернетом) – понятное дело, что у нас тут будут статические настройки:

  • Сеть провайдера: 277.146.101.0
  • Маска: 255.255.255.252 (/30)
  • Шлюз: 277.146.101.1

Я придумал все эти значения, просто чтобы показать настройку – вы же подставляйте свои циферки. Маршрутизатор будет выступать шлюзом, и наша задача связать две эти сети и дать клиентам доступ в интернет.

Давайте введем настройки внешнего статического адреса:

WIFIGID-ROUTER #conf t
WIFIGID-ROUTER (config)#
interface Fa 4
ip address 227.146.101.2 255.255.255.252
no shutdown

Для подключения к интернету мы используем четвёртый интерфейс. Выше я задал внешний IP как 227.146.101.2, после этого прописал маску и запустил настройку последней командой. Ах да, не забудьте подключить интернет кабель от провайдера. В качестве проверки пингуем сначала сам роутер:

WIFIGID-ROUTER #ping 227.146.101.2

А потом шлюз провайдера:

WIFIGID-ROUTER #ping 227.146.101.1

Если все хорошо, и оба устройства пингуются, идем настраивать интерфейс для связи с локальной сетью. Локальная сеть у нас будет с адресацией:

Локальный адрес роутера:

И еще один совет – обязательно оставьте пару адресов про запас. То есть диапазон адресов будет примерно от 192.168.1.2 до 192.168.1.10. Остальные уже будут использоваться клиентами и другими устройствами в локалке.

Читайте так же:
Как настроить Табло в Яндекс.Браузере

Локальный адрес роутера мы будем прописывать в VLAN:

R-DELTACONFIG#conf t
interface Vlan 1
Ip address 192.168.2.1 255.255.255.0
no shutdown
interface Fa 0
switchport access vlan 1
no shutdown

А для подключения будем использовать интерфейс «Fa 0». Что мы сделали, мы привязали сначала локальный адрес к Vlan. А потом уже VLAN привязали к физическому интерфейсу. Подключаем к этому физическому интерфейсу наш коммутатор, к которому уже будут подключены все рабочие машины, принтеры и другие сетевые устройства.

ШАГ 4: Удаленный доступ к роутеру

Чтобы вам постоянно не сидеть рядом с роутером и подключенным к нему консольным кабелем, я вам советую сразу настроить удалённый доступ. Мы будем использовать подключение по защищенному каналу SSH (второй версии).

WIFIGID-ROUTER (config)#
ip ssh ver 2
ip domain-name wifigid-router-c.ru

Сначала мы запустили SSH-2, а потом прописали произвольный домен. Теперь создаем ключ с помощью команды.

crypto key generate rsa

Далее вылезет вот такая вот надпись:

Как настроить роутер Cisco: пример и реализация от WiFiGid

Создаем пользователя с правами админа и паролем. Вместо «password» введите свой пароль.

username admin privilege 15 secret 0 password

Включаем пользователя в базу устройства:

line vty 0 4
login local

И задаем пароль для режима доступа:

enable secret 0 password-2

Опять же вместо «password-2» вводим свой пароль. После этого вы можете использовать любую программу с поддержкой SSH для доступа из локальной сети к этому роутеру.

ШАГ 5: Настройка шлюза

Теперь нам нужно подключиться к шлюзу провайдера:

WIFIGID-ROUTER (config)#
ip route 0.0.0.0 0.0.0.0 227.146.101.1

После этого пингуем любой внешний сайт, но лучше использовать именно IP, а не DNS адрес. Можно даже пропинговать один из DNS-серверов.

WIFIGID-ROUTER#ping 8.8.8.8

ШАГ 6: Настройка NAT

Опять же локальные компьютеры пользователя пока не имеют доступа в интернет, но мы это исправим. Для этого нам нужно настроить динамическую трансляцию локальных IP во внешний. У нас всего один внешний адрес, поэтому локальные адреса должны превращаться в него, проходя через наш роутер, выполняющий роль шлюза.

Прописываем диапазон тех адресов, которые в теории могут использоваться локальными машинами:

WIFIGID-ROUTER (config)#
ip access-list standard ACL_NAT
permit 192.168.1.0 0.0.0.255

Далее указываем наш VLAN:

Interface Vlan 1
ip nat inside

Они будет неким локальным интерфейсом, ведь в VLAN может быть сразу несколько адресов. Теперь указываем физический внешний интерфейс, к которому мы подключили провайдерский кабель:

Interface Fa 4
ip
nat outside

А теперь мы создаем NAT правило:

ip nat inside source list WIFIGID_NAT interface fa4

Далее мы уже можем из локальной сети с любого компа клиента пинговать любые интернет-адреса. Также в качестве пробы используем внешний IP адрес. Ну и в самом конце не забудьте сохранить конфиг в память роутера:

Видео

Шаблон базовой настройки маршрутизатора Cisco

В последнее время приходится часто настраивать с нуля маршрутизаторы Cisco (в основном 800-1800 серии) для филиалов моей компании и дабы не набирать одни и теже команды третий десяток раз составил для себя небольшой шаблон настроек на разные случаи жизни. Сразу скажу что сертификаты от Cisco не получал, книжек по данным роутерам особо не читал, весь свой опыт приобрел методом научного тыка, курением мануалов на cisco.com и кое каким вдумчивым заимствованием кусков чужих конфигов…

Итак распаковываем роутер, заливаем последнюю прошивку (для SSH необходим минимум Advanced Security), делаем
#erase startup-config
дабы избавится от преднастроеного мусора и перегружаемся.

Настройка авторизации и доступа по SSH

! включаем шифрование паролей
service password-encryption
! используем новую модель ААА и локальную базу пользователей
aaa new-model
aaa authentication login default local
! заводим пользователя с максимальными правами
username admin privilege 15 secret PASSWORD

! даем имя роутеру
hostname <. >
ip domain-name router.domain
! генерируем ключик для SSH
crypto key generate rsa modulus 1024
! тюнингуем SSH
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
! и разрешаем его на удаленной консоли
line vty 0 4
transport input telnet ssh
privilege level 15

Настройка роутинга

! включаем ускоренную коммутацию пакетов
ip cef

Настройка времени

! временная зона GMT+2
clock timezone Ukraine 2
clock summer-time Ukraine recurring last Sun Mar 2:00 last Sun Oct 2:00
! обновление системных часов по NTP
ntp update-calendar
! ntp сервера лучше задавать по айпи, ибо если при перегрузке DNS-сервера не доступны то настройки по именам слетают…
ntp server NTP.SERVER.1.IP
ntp server NTP.SERVER.2.IP

Читайте так же:
Срок службы впитывающей чернила подкладки принтера заканчивается
Архивирование конфигов

! включаем архивирование всех изменений конфига, скрывая пароли в логах
archive
log config
logging enable
hidekeys

! историю изменения конфига можно посмотреть командой
show archive log config all

Настройка DNS

! включить разрешение имен
ip domain-lookup
! включаем внутренний DNS сервер
ip dns server
! прописываем DNS провайдера
ip name-server XXX.XXX.XXX.XXX
! на всякий случай добавляем несколько публичных DNS серверов
ip name-server 4.2.2.2
ip name-server 208.67.222.222
ip name-server 208.67.220.220

Настройка локальной сети

! обычно порты внутреннего свитча на роутере объединены в Vlan1
interface Vlan1
description === LAN ===
ip address 192.168. 1

! включаем на интерфейсе подсчет пакетов передаваемых клиентам — удобно просматривать кто съедает трафик
ip accounting output-packets

! посмотреть статистику можно командой
show ip accounting
! очистить
clear ip accounting

Настройка DHCP сервера

! исключаем некоторые адреса из пула
ip dhcp excluded-address 192.168. 1 192.168. 99
! и настраиваем пул адресов
ip dhcp pool LAN
network 192.168. 0 255.255.255.0
default-router 192.168. 1
dns-server 192.168. 1

Настройка Internet и Firewall

! настраиваем фильтр входящего трафика (по умолчанию все запрещено)
ip access-list extended FIREWALL
permit tcp any any eq 22

! включаем инспектирование трафика между локальной сетью и Интернетом
ip inspect name INSPECT_OUT dns
ip inspect name INSPECT_OUT icmp
ip inspect name INSPECT_OUT ntp
ip inspect name INSPECT_OUT tcp router-traffic
ip inspect name INSPECT_OUT udp router-traffic
ip inspect name INSPECT_OUT icmp router-traffic

! настраиваем порт в Интернет и вешаем на него некоторую защиту
interface FastEthernet0/0
description === Internet ===
ip address . 255.255.255.
ip virtual-reassembly
ip verify unicast reverse-path
no ip redirects
no ip directed-broadcast
no ip proxy-arp
no cdp enable
ip inspect INSPECT_OUT out
ip access-group FIREWALL in

! ну и напоследок шлюз по умолчанию
ip route 0.0.0.0 0.0.0.0 .

Настройка NAT

! на Интернет интерфейсе
interface FastEthernet0/0
ip nat outside

! на локальном интерфейсе
interface Vlan1
ip nat inside

! создаем список IP имеющих доступ к NAT
ip access-list extended NAT
permit ip host 192.168. any

! включаем NAT на внешнем интерфейсе
ip nat inside source list NAT interface FastEthernet0/0 overload

! добавляем инспекцию популярных протоколов
ip inspect name INSPECT_OUT http
ip inspect name INSPECT_OUT https
ip inspect name INSPECT_OUT ftp

Отключение ненужных сервисов

no service tcp-small-servers
no service udp-small-servers
no service finger
no service config
no service pad
no ip finger
no ip source-route
no ip http server
no ip http secure-server
no ip bootp server

UPD. Убрал лишнее по советам хаброюзеров
UPD2. Добавил отключение ненужных сервисов
UPD3. Изменил настройка файрвола (спасибо Fedia)

Как настроить маршрутизатор

Если вы уделили должное внимание выбору маршрутизаторов, то скорее всего, остановились на модели с удобными инструментами для настройки, например через мобильное приложение или веб-панель. Поскольку все маршрутизаторы различаются, различаются и процедуры их настройки. Ниже описаны основные этапы настройки, которые применимы практически ко всем маршрутизаторам.

Связаться с Cisco

Прежде чем начать

Проверьте подключение к Интернету

При нестабильном подключении к Интернету вы можете столкнуться с трудностями при настройке маршрутизатора. Самый простой способ — подключить компьютер к модему или шлюзу, предоставленному вашим Интернет-провайдером. Если компьютер обнаружит подключение к Интернету, можно приступать к настройке маршрутизатора.

Подготовьте инструкции

Хотя это и очевидно, но именно так вы можете избежать сложностей в ходе настройки. Следуйте инструкциям на наклейках и в бумажных руководствах, где может содержаться важная информация по настройке (например, имя пользователя и пароль маршрутизатора по умолчанию).

Проверьте наличие приложения

Многие производители маршрутизаторов предлагают мобильные приложения или веб-панель для настройки и управления. Если вы используете приложение на смартфоне, возможно, для настройки маршрутизатора вам даже не придется подключать его к компьютеру. Проверьте в документации к компьютеру, есть ли в наличии такое приложение.

Прикрепите и раздвиньте антенны

Если у маршрутизатора есть антенны, которые не закреплены на его корпусе, их нужно установить. Кроме того, прежде чем начать настройку, следует раздвинуть эти антенны.

Читайте так же:
Как отключить клавиатуру на ноутбуке с Windows 7

Начните с бесплатной пробной версии облачной сети Cisco

Вам также может пригодиться следующая информация:

Видео

Инструкция по настройке маршрутизатора

Шаг 1. Выберите место размещения маршрутизатора

Для установки беспроводного корпоративного маршрутизатора лучше всего подходит открытое пространство в офисе — так вы обеспечите равномерное покрытие. Но иногда найти открытое пространство бывает непросто, потому что маршрутизатор нужно подключить к широкополосному шлюзу от интернет-провайдера, обычно соединенному с кабелем возле наружной стены.

Шаг 2. Установите подключение к Интернету

Подключите маршрутизатор к кабелю или выберите маршрутизатор с поддержкой ячеистой сети.

Если маршрутизатор установлен далеко, используйте кабель CAT5e или CAT6 для его подключения к порту Ethernet на шлюзе от Интернет-провайдера. Также можно протянуть кабели Ethernet по стенам в офисе к выбранному центральному месту расположения маршрутизатора.

Еще один вариант — создать ячеистую сеть с помощью маршрутизатора. В ячеистой сети вы можете разместить в офисе или дома несколько передатчиков Wi-Fi, которые связаны в одной сети. В отличие от ретрансляторов, которые можно использовать с любым беспроводным маршрутизатором, для ячеистых сетей нужен маршрутизатор со встроенной поддержкой этой возможности.

Какой бы вариант вы ни выбрали, вам понадобится обычный кабель Ethernet, подключенный к порту WAN или интернет-порту на маршрутизаторе. Обычно интернет-порт выделен другим цветом, чтобы его было легко отличить от других портов.

Проверьте индикаторы маршрутизатора

С помощью индикаторов на маршрутизаторе можно определить, удалось ли установить подключение к Интернету. Если индикаторы не светятся, убедитесь, что подключили кабель в соответствующий порт.

Проверьте подключение с помощью устройства.

Чтобы проверить, установлено ли подключение на маршрутизаторе, подключите ноутбук к одному из портов для устройств на задней стороне маршрутизатора. Если все в порядке, вы сможете установить проводное подключение как при проверке успешного подключения к Интернету.

Шаг 3. Настройте шлюз беспроводного маршрутизатора

Иногда интернет-провайдеры предоставляют клиентам шлюзы со встроенными маршрутизаторами. В большинстве случаев эти комбинированные устройства не созданы для корпоративного использования, и при этом у них нет дополнительных портов, функций обеспечения безопасности и других возможностей, которые позволяют добавлять услуги и расширять сети по мере развития компании.

Если у вас есть шлюз со встроенным маршрутизатором, отключите маршрутизатор на шлюзе и настройте передачу IP-адреса интерфейса WAN — уникального IP-адреса, который интернет-провайдер назначает вашей учетной записи и всему сетевому трафику, проходящему через ваш новый маршрутизатор.

Если этот шаг не выполнить, могут возникнуть конфликты, из-за которых устройства не смогут корректно работать. Если вам понадобится помощь с выполнением этих действий, обратитесь к своему интернет-провайдеру.

Шаг 4. Подключите шлюз к маршрутизатору

Сначала отключите шлюз. Если кабель Ethernet уже подключен к порту LAN на шлюзе, отсоедините этот кабель и подключите его к порту WAN на маршрутизаторе. Снова включите шлюз и подождите несколько минут, пока он загрузится. Подключите источник питания маршрутизатора, включите его и подождите — это тоже займет несколько минут.

Шаг 5. Выполните настройку через приложение или веб-панель

Самый простой способ дальнейшей настройки маршрутизатора — через мобильное приложение, если его предоставляет производитель маршрутизатора. Если такого приложения нет, лучше использовать веб-панель маршрутизатора для его подключения к компьютеру с помощью кабеля Ethernet.

IP-адрес маршрутизатора обычно напечатан на задней панели самого устройства. Если там его нет, на панели поиска в браузере введите 192.168.1.1 — стандартный адрес маршрутизатора.

Шаг 6. Создайте имя пользователя и пароль

Чтобы настроить маршрутизатор, нужно войти в систему, указав имя администратора и пароль по умолчанию. Как правило, эта информация размещена на самом маршрутизаторе или в руководстве, которое к нему прилагается.

Затем введите нужные учетные данные. После входа в учетную запись сразу измените имя пользователя и пароль. По умолчанию установлены часто используемые сочетания (например, admin и password1234), поэтому сохранять их небезопасно. При первой возможности измените эти учетные данные.

Шаг 7. Обновите микропрограммное обеспечение маршрутизатора

Для маршрутизатора может потребоваться обновление микропрограммного или программного обеспечения, под управлением которых он работает. Проведите обновление как можно скорее, поскольку в новой версии микропрограммного обеспечения, возможно, устранены ошибки или добавлены новые способы защиты.

Читайте так же:
Как заблокировать всплывающие окна в Опере

Некоторые маршрутизаторы загружают новые версии микропрограммного обеспечения автоматически, но большинство маршрутизаторов такую возможность не поддерживает. Наличие обновлений нужно проверять через приложение или веб-интерфейс.

Шаг 8. Укажите пароль для сети Wi-Fi

На многих маршрутизаторах уже заданы имя пользователя и пароль не только для администратора, но и для сети Wi-Fi. Возможно, вы уведите запрос на изменение имени пользователя и пароля для сети Wi-Fi. Если этого не произойдет, постарайтесь их сменить в скором времени.

Шаг 9. По возможности используйте инструменты автоматической конфигурации

Если маршрутизатор поддерживает функции автоматической установки, используйте их при выполнении настройки. Например, вы можете применить автоматическую конфигурацию для управления IP-адресами по протоколу DHCP: он автоматически назначает IP-адреса устройствам. Эти адреса вы можете в любой момент изменить.

Шаг 10. Установите настройки безопасности

Многие производители маршрутизаторов предлагают функции обеспечения безопасности для защиты сети и конфиденциальности пользователей. Вы можете выполнить вход в веб-панель и включить дополнительные функции обеспечения безопасности, например межсетевой экран, фильтрацию веб-содержимого и управление доступом, чтобы защититься от вредоносного трафика. А для обеспечения конфиденциальности вы можете настроить сети VPN.

Маршрутизатор Cisco — начальная настройка

При первоначальной настройки маршрутизатор cisco необходимо подключить к COM порту компьютера, посредством специального консольного кабеля.

Кабель представляет собой с одной стороны разъём DB9 (female/мама) для подключения к COM порту компьютера, а с другой RJ-45 для подключения к консольному порту маршрутизатора (порт обведён в голубой цвет и имеет надпись Console, либо просто надпись Console на голубом фоне).

Консольный кабель Cisco

Консольный кабель Cisco

Консольные порты Cisco

Консольные порты Cisco

Новые модели маршрутизаторов, например Cisco 2900 Series Integrated Services Routers (ISR), имеют как RJ-45 консольный порт, так и консольный порт mini-USB Type B.

Mini-USB порт позволяет подключаться к консоли через USB кабель, если вдруг в компьютере отсутствует COM порт. Если настройка роутера производится через USB кабель на компьютере с Microsoft Windows, на компьютер необходимо установить драйвер Cisco Microsoft Windows USB Device Driver.

Кабель Mini USB

Кабель Mini USB

Консольный порт USB имеет приоритет над RJ-45. При настройке одновременное использование консольных портов не допускается.

Для настройки устройства через консольный кабель на компьютере с Microsoft Windows можно использовать встроенную программу Hyper Terminal, для меня она не очень удобна, поэтому я использую Putty (возможно это просто дело привычки). В программе, будь то Putty, Hyper terminal или ещё какая-либо, необходимо настроить параметры порта (COM) следующим образом:

Скорость (бит/с): 9600

Стоповые биты: 1

Управление потоком: нет

Пример настройки в Putty:

Настройка COM порта в Putty

Настройка COM порта в Putty

Окно запуска консоли в Putty

После чего, если маршрутизатор включен и соединен с компьютером консольным кабелем, в окне терминала (по нажатию на Enter) появится интерфейс командной строки. Так же здесь можно наблюдать и процесс загрузки устройства.

Можно приступать к настройке устройства.

Логин/пароль по умолчанию обычно либо cisco/cisco либо пустой пароль на вход в привилегированный режим.

Входим в привилегированный режим командой «enable»:

Очищаем существующую конфигурацию командой «erase startup-config»:

Router#
Router#erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
Router#
*Mar 1 00:10:46.519: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram
Router#

Перезагружаем роутер командой «reload» и подтверждаем её:

Router#reload
Proceed with reload? [confirm]

*Mar 1 00:14:52.907: %SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload command.

Так как мы стерли конфигурационный файл startup-config, то после перезагрузки предлагается пройти мастер начальной настройки системы, в котором предлагается вести имя маршрутизатора, пароли для различных режимов, IP адрес на интерфейсе управления и прочее. Я обычно на запрос запуска мастера отвечаю: no , а все необходимые параметры ввожу вручную.

Мастер настройки Cisco

Пишем no и жмём Enter.

Переходим в режим глобального конфигурирования системы командой «configure terminal» (сперва не забываем перейти в привилегированный )

Router>
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#

Видно как изменилась строка приглашения на «Router(config)# » — означает, что мы находимся в глобальном режиме конфигурации системы

Читайте так же:
Как скачивать музыку с ВК в Опере

Задаём пароль на вход в привилегированный режим командой «enable secret»

Router(config)#enable secret 0 pass123
Router(config)#

0 — означает ввод пароля в не зашифрованном виде, но храниться будет он в шифрованном.

pass123 — сам пароль

Устанавливаем имя маршрутизатора командой «hostname»

Задаём имя домена командой «ip domain-name»

RTR1(config)#
RTR1(config)#ip domain-name test.ru
RTR1(config)#

Прописываем время, дату и часовой пояс. Задать время и дату можно просто в привилегированном режиме, не переходя в режим глобального конфигурирования системы, а вот часовой пояс только в режиме конфигурации.

Время и дата командой «clock set» (например 26 марта 2013 года, 19 часов 32 минуты 30 секунд):

RTR1#
RTR1#clock set 19:32:30 26 Mar 2013
RTR1#

Часовой пояс командой «clock timezone» (например смещение по UTC в +10 часов):

RTR1#
RTR1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
RTR1(config)#
RTR1(config)#clock timezone YST 10
RTR1(config)#

Включаем аутентификацию и заводим пользователя.

RTR1(config)#
RTR1(config)#aaa new-model
RTR1(config)#aaa authentication login default local
RTR1(config)#

Команда «aaa new-model» — активирует возможность использования функций и команд для аутентификации, авторизации, аккаунтинга (AAA)

Команда «aaa authentication login default local» — включает аутентификацию при попытке сделать logon, и проверяет пользователя и пароль по локальной базе.

После ввода этих команд, нужно создать пользователя, иначе нельзя будет зайти на маршрутизатор ни по ssh/telnet, ни через консоль.

Создаём пользователя petya с паролем password123:

RTR1(config)#
RTR1(config)#username petya secret 0 password123
RTR1(config)#

Настраиваем сетевой интерфейс. Что бы настроить сетевой интерфейс, нужно перейти из режима глобального конфигурирования в режим конфигурирования интерфейса.

RTR1(config)#
RTR1(config)#interface fastEthernet 0/0
RTR1(config-if)#ip address 192.168.56.254 255.255.255.0
RTR1(config-if)#no shutdown
RTR1(config-if)#
RTR1(config-if)#
Mar 26 19:51:11.851: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
Mar 26 19:51:12.851: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
RTR1(config-if)#
RTR1(config-if)#exit
RTR1(config)#

Команда «interface fastEthernet 0/0» — переводит в режим конфигурирования интерфейса. В данном случае у нас интерфейс называется «fastEthernet «, в зависимости от модели роутера, могут быть другие названия например ethernet или gigabitEthernet. Информацию о состоянии интерфейсов можно посмотреть командой «show interfaces»

Команда «ip address 192.168.56.254 255.255.255.0» — задаёт IP адрес и сетевую маску на интерфейсе

Команда «no shutdown» — включает интерфейс

Команда «exit» — производит выход из режима конфигурации интерфейса в глобальный режим конфигурации.

Разрешаем удаленный доступ к устройству по telnet или ssh. Не все версии IOS поддерживают ssh (необходима поддержка шифрования). Поэтому в некоторых случаях приходится настраивать удаленный доступ и для telnet. Для настройки ssh необходимо сперва сгенерировать ключи.

Генерируем ключи командой «crypto key generate rsa»:

RTR1(config)#
RTR1(config)#crypto key generate rsa
The name for the keys will be: RTR1.test.ru
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]:
% Generating 512 bit RSA keys . [OK]

RTR1(config)#
Mar 26 20:16:47.879: %SSH-5-ENABLED: SSH 1.5 has been enabled
RTR1(config)#

Как только сгенерировались ключи, в консоли вышло сообщение, что ssh включен. Кстати, для генерации ключей необходимо сперва задать имя домена и желательно выставить правильное время, что я уже сделал выше.

Разрешаем ssh и telnet на линиях виртуальных терминалов:

RTR1(config)#
RTR1(config)#line vty 0 4
RTR1(config-line)#transport input telnet ssh
RTR1(config-line)#exec-timeout 60
RTR1(config-line)#
RTR1(config-line)#exit
RTR1(config)#

Команда «line vty 0 4» — переводит в режим конфигурирования линий VTY с 0 по 4

Команда «transport input telnet ssh» — разрешает вход через telnet и ssh на терминалы vty

Команда «exec-timeout 60» — отключает от линии пользователя после 60 минут бездействия

команда «exit» — выход из режима конфигурировании линий в глобальный режим.

В данном случае разрешён удаленный доступ с любых IP адресов, что бы ограничить, необходимо создавать ACL и вешать их на линии.

Сохраняем конфигурацию. Всё, что мы сейчас настроили будет работать до первой перезагрузки. Что бы конфиг сохранился его нужно сохранить командой «copy running-config startup-config»:

RTR1(config)#exit
RTR1#copy running-config startup-config
Building configuration.
[OK]
RTR1#

Ссылка на основную публикацию
Adblock
detector